1. Forum moved (you can use login and pass from old forum)
  2. Many discussions moved to the bugtracker

Mac OS X

Discussion in 'Ports' started by sparkstar, Sep 10, 2014.

  1. sparkstar

    sparkstar Registered
    54/56

    Joined:
    Sep 10, 2014
    Messages:
    3
    Likes Received:
    0
    Best Answers:
    0
    [​IMG]
    hi

    i tested openapoc run normally on mac(10.9.4). we need a two step.

    1. dependencies install using brew
    2. modify CMakeLists.txt

    add library 'allegro_main' because compiler cannot find '_al_mangled_main' on mac, clang++ so occured linking failed..
    after modify cmakelists i tested mac and ubuntu 12.04.

    i created pull request. please check and test. thank you.
     
  2. JonnyH

    JonnyH Well-Known Member Official Developer Administrator
    64/112

    Joined:
    Jul 17, 2014
    Messages:
    183
    Likes Received:
    36
    Best Answers:
    0
    This looks pretty good, I'm currently moving house at the minute (no internet at home!) so I'll test this and merge it when I can.

    I'm afraid I don't have access to any apple hardware, so you're likely on your own here, but the more platforms the better - we'll be trying to use cross-platform libraries where possible to help this but it's always easier if someone is actively testing it and letting us know when we break everything sooner rather than later...

    Jonny
     
  3. pmprog

    pmprog Well-Known Member Official Developer Administrator
    54/56

    Joined:
    Jul 8, 2014
    Messages:
    175
    Likes Received:
    12
    Best Answers:
    0
    Pretty much what JonnyH said...

    But I had to comment, cos you're using QtCreator. It's one of my fave IDEs, but I never really figured out how to do non-Qt projects in it...

    About allegro_main, I don't think this was an issue on my side because I just linked to the monolith build, which has everything in one lib
     

Share This Page